Arch Linux е все по-близо до още по-бързо инсталиране на пакети с Pacman чрез Zstd компресия

1
64
Arch Linux

От екипа на Arch Linux ще предоставят още по-бързо инсталиране на пакети с Pacman и Zstd компресия.

Много потребители, използващи Arch Linux знаят колко бърз е Pacman в сравнение с другите пакетни мениджъри. Сега това положение ще се подобри значително с идването на версия 5.2, в която е добавена поддръжка за Zstd компресиране.

Zstd носи със себе си по-бързо компресиране и декомпресиране, но в същото време предоставя ниво на компресия, сравнимо с това XZ. Това се очаква да повиши скоростта на pacman още повече, без никакви други негативни ефекти.

Pacman 5.2 се очаква да излезе съвсем скоро, а за да могат потребителите да използват Zstd компресията на пакетите ще трябва да имат инсталирана libarchive библиотеката с поддръжка за Zstd, която се предлага в хранилищата от септември 2018-а година.

От екипа на Arch Linux съобщават, че минималната версия на libarchive, която ви е необходима е libarchive 3.3.3-1 и подчертават, че са дали едногодишен период на потребителите да обновят до по-нова версия и очакват това наистина да се е случило, а ако не сте, да побързате.

Zstd пакетите ще имат файлово разширение .pkg.tar.zst .

Официалния анонс можете да видите тук.

5/5 (3 Reviews)
Прочетете още:  SpellForce 3 Linux DXVK Wine

1
Leave a Reply

avatar
1 Коментари
0 Отговори на коментари
0 Последователи
 
Коментари с най-много реакции
Най-горещ коментар
1 Автори на коментари
Валсо Автори на последни коментари
  Абониране  
нови стари оценка
Извести ме за
Валсо
Потребител

[rado@arch]: ~>$ search libarchive
core/libarchive 3.4.0-2 [инсталиран]

Така че няма от какво да се притеснявам, а само да чакам заветния ъпдейт. 😀