Linux инсталаторът Calamares се приготвя за Wayland

0
14
Linux инсталаторът Calamares се приготвя за Wayland


Инсталаторът Calamares вече е с нова версия 3.1.1. Разработчиците обявиха и някои интересни планове за версия 3.2.

Calamares UIF (The universal installer framework) се използва в множество GNU/Linux дистрибуции като Manjaro, KaOS, KDE Neon, GeckoLinux, Sabayon, Netrunner и още много други.

В новата версия 3.1.1 е поправена слабост при паролите и всички дистрибуции, които използват Calamares трябва да я предоставят на потребителите си възможно най-скоро.

Плановете на разработчиците за следващите три месеца са за още две малки версии 3.1.2 и 3.1.3, както и голямата версия 3.2.

Голямата версия 3.2 ще дойде с една голяма промяна. В блог пост разработчиците обясняват, че бъдещето при графичните сървъри е Wayland и Calamares също ще трябва да премине от X11 към Wayland, което обаче е свързано с някои трудности, които трябва да бъдат решени.

Един от основните проблеми е, че setuid-root приложенията не могат да се свързват с дисплей сървъра. Възможно решение на този проблем е да не се изисква root парола в частта на потребителския интерфейс на Calamares, което пък от своя страна означава, че ще трябва да има по-добро разделение между фронтенда (потребителския интерфейс) и бекенда (root).

Това ще доведе до още различни промени, които ще трябва да се нанесат, като например за различните модули, които са извън хранилището на Calamares, където ще трябва да се правят допълнителни настройки за различната структура на правата.

Други подобрения, които са планирани и могат да бъдат въведени при следващите издания от серията 3.1, както и при Calamares 3.2, са преводи на .desktop файла и на обикновените Python модули, като към момента няма никакви преводи за тях.

Прочетете още:  От Purism споделиха последните новости за Linux смартфона Librem 5

Ще се работи и по подобряване на проверката на хардуера, защото има случаи, когато приветствената страница на инсталатора мисли, че има достатъчно място на хард диска, докато партишън мениджърът не разполага с такова.

Очаква се и още една голяма промяна и тя е спирането на поддръжката за Boost::Python имплементацията и използването на всички Python модули във вграден Python интерпретатор. Засега тази промяна не е ясно дали ще бъде въведена във версия 3.2 или 3.3.

Повече детайли можете да видите в този блог пост.

0/5 (0 Reviews)
Абониране
Извести ме за
guest
0 Comments
Inline Feedbacks
View all comments